Функция наибольший в excel примеры

Функция наибольший в excel примеры

Очень часто нам необходимо найти в выборке чисел или дат наибольшие или наименьшие числа. Для этих целей есть специальные функции НАИБОЛЬШИЙ и НАИМЕНЬШИЙ. Их синтаксис следующий:

Где Массив – это диапазон данных/чисел из которых необходимо выбрать наибольшее или наименьшее число, а k – это позиция, начиная с которого необходимо считать. То есть, если поставить цифру 1, то будут находиться самые крайние значения (самое максимальное или минимальное), если 2 – то второе по величине и так далее.

Давайте, для наглядности, разберем какой-нибудь простенький пример.

Допустим у нас таблица со счетами и датами их оплаты. Даты не отсортированы по возрастанию. Все даты уникальные, то есть, нет одинаковых. Нам необходимо постоянно искать ближайшие две даты, для того, чтобы оплатить их. Можно находить даты вручную, можно отсортировывать постоянно, а можно прописать простую формулу с использованием функции НАИМЕНЬШИЙ

Находим ближайшую дату:

Находим следующую дату:

Надеемся, что вам понятно почему мы используем в этой формуле цифру 2.

Но после ввода формулы вы увидите, что результат будет указан не в виде даты, а в виде цифр, например, в нашем случае ближайшая дата будет 13.09.2013, но вместо не будет указано число 41530, это и есть наша дата, только в числовом формате. Чтобы отобразить в формате даты необходим выделить эти ячейки, нажать правую кнопку мыши и выбрать «Формат ячеек…», выбрать «Формат даты» и необходимый вид как показано на рисунке.

Все, наша формула готова. Теперь ближайшие даты будут автоматически обновляться.

Надеемся, что статья была вам полезна и вы отблагодарите нас, нажав «Мне нравиться» чуть ниже на этой странице. Спасибо

Возможность проведения логических проверок в ячейках является мощным инструментом. Вы найдете бесконечное количество применений для ЕСЛИ()

в ваших повседневных документах. Проблема заключается в том, что часто необходимые проверки выходят за рамки возможностей простой функции ЕСЛИ(). Это происходит, когда необходимо сделать проверку на два и более условия до принятия результата.

Для таких случаев в Excel предусмотрено несколько вариантов: использование ЕСЛИ() внутри другого ЕСЛИ(), функции И() и ИЛИ(). Далее мы познакомимся с этими способами.

Использование ЕСЛИ() внутри другой функции ЕСЛИ()

Давайте рассмотрим вариант на основе изученной ранее функции =ЕСЛИ(А1>1000;"много"; "мало") . Что если вам необходимо вывести другую строку, когда число в А1 является, например, большим, чем 10.000? Другими словами, если выражение А1>1000 верно, вы захотите запустить другую проверку и посмотреть, верно ли, что А1>10000. Такой вариант вы можете создать, применив вторую функцию ЕСЛИ() внутри первой в качестве аргумента значение _если_истина: =ЕСЛИ(А1>1000;ЕСЛИ(А1>10000;"очень много"; "много");"мало") .

Если А1>1000 является истинным, запускается другая функция ЕСЛИ(), возвращающая значение «очень много», когда А1>10000. Если же при этом А1 меньше или равно 10000, возвращается значение «много». Если же при самой первой проверке число А1 будет меньше 1000, выведется значение «мало».

Читайте также:  Как найти вес шара

Обратите внимание, что с таким же успехом вы можете запустить вторую проверку, в случае если первая будет ложной (то есть в аргументе значение_если_ложь функции еслио ). Вот небольшой пример, возвращающий значение «очень мало», когда число в А1 меньше 100: =ЕСЛИ(А1>1000;"много";ЕСЛИ(А1 .

Расчет бонуса с продаж

Хорошим примером использования одной проверки внутри другой проверки является расчет бонуса с продаж персоналу. который работает в Клуб — отель Гелиопарк Талассо, Звенигород. В данном случае, если значение равно X, вы хотите получить один результат, если У — другой, если Z — третий. Например, в случае вычисления бонуса за успешные продажи возможны три варианта:

  1. Продавец не достиг планового значения, бонус равен 0.
  2. Продавец превысил плановое значение менее чем на 10%, бонус равен 1 000 рублей.
  3. Продавец превысил плановое значение более чем на 10%, бонус равен 10 000 рублей.

Вот формула для расчета такого примера: =ЕСЛИ(Е3>0;ЕСЛИ(Е3>0.1;10000;1000);0) . Если значение в Е3 является отрицательным, то возвращается 0 (нет бонуса). В случае когда результат положительный, проверяется, больше ли он 10%, и в зависимости от этого выдается 1 000 или 10 000. Рис. 4.17 показывает пример работы формулы.

Функция И()

Часто бывает необходимо провести проверку только на верность одновременно двум условиям. Например, выплата бонуса осуществляется, только когда продажи определенного товара превысили план и также общие продажи превысили план. Если одно из данных условий не выполняется (или оба условия), премия не выплачивается. В булевой логике это называется логическим И, поскольку оба условия должны быть истинны для истинности всего выражения.

В Excel выражения логического И обрабатываются с помощью функции И(): И(логическое_значение1;логическое_значение2;…). Каждый аргумент представляет собой логическое значение для проверки. Вы можете ввести столько аргументов, сколько вам необходимо.

Еще раз отметим работу функции:

  • Если все выражения возвращают ИСТИНА (или любое положительное число), И() возвращает ИСТИНА.
  • Если один или более аргументов возвращают ЛОЖЬ (или 0), И() возвращает ЛОЖЬ.

Чаще всего И() применяется внутри функции ЕСЛИ(). В таком случае, когда все аргументы внутри И() вернут ИСТИНА, функция ЕСЛИ() пойдет по своей ветке значение если истина. Если одно или более из выражений в И() вернет ЛОЖЬ, функция ЕСЛИ() пойдет по ветке значение_если_ложь.

Вот небольшой пример: =ЕСЛИ(И(С2>0;В2>0);1000;"нет бонуса") . Если значение в В2 будет больше нуля и значение в С2 будет больше нуля, формула вернет 1000, в противном случае выведется строка «нет бонуса».

Разделение значений по категориям

Полезным применением функции и () является разделение по категориям в зависимости от значения. Например, у вас имеется таблица с результатами какого-то опроса или голосования, и вы хотите разделить все голоса на категории в соответствии со следующими возрастными рамками: 18-34,35-49, 50-64,65 и более. Предполагая, что возраст респондента находится в ячейке В9, следующие аргументы функции и () проводят логическую проверку на принадлежность возраста диапазону: =И(В9>=18;В9 .

Читайте также:  Шехзаде перевод на русский

Если ответ человека находится в ячейке С9, следующая формула выведет результат голосования человека, если срабатывает проверка на соответствие возрастной группе 18-34: =ЕСЛИ(И(В9>=18;В9 . На рис. 4.18 вы видите определенную информацию по данному примеру. Вот формулы, использующиеся в других столбцах:

  • 35-49: =ЕСЛИ(И(В9>=35;В9 =50;В9 =65;С9;«»)

Функция ИЛИ()

Существуют ситуации, когда вам необходимо решение, только когда одно из условий принимает положительное значение (ИСТИНА). Например, вы можете решить выплатить бонус сотрудникам, когда общие продажи превышают план или когда продажи отдельного товара превысили прогноз. В булевой логике это называется логическим ИЛИ.

Такие условия проверяются в Excel с помощью функции ИЛИ(): ИЛИ(логическое_значение1; логическое_значение2;…). Каждый аргумент представляет собой логическое значение для проверки. Вы можете ввести столько аргументов, сколько вам необходимо. Результат работы ИЛИ() зависит от следующих условий:

  • Если один аргумент или более возвращает ИСТИНУ (любое положительное число), ИЛИ() возвращает ИСТИНУ.
  • Если все аргументы возвращают ЛОЖЬ (нулевое значение), результатом работы ИЛИ() будет ЛОЖЬ.

Так же как и И(), чаще всего функция ИЛИ() используется внутри проверки ЕСЛИ(). В таком случае, когда один из аргументов внутри ИЛИ() вернет ИСТИНА, функция ЕСЛИ() пойдет по своей ветке значение_если_истина. Если все выражения в ИЛИ() вернут ЛОЖЬ, функция ЕСЛИ() пойдет по ветке значение_если_ложь. Вот небольшой пример: = ЕСЛИ(ИЛИ(С2>0;В2>0);1000;"нет бонуса") .

В случае когда в одной из ячеек (С2 или В2) будет положительное число, функция вернет 1000. Только когда оба значения будут отрицательны (или равны нулю), функция вернет строку «нет бонуса».

В этом уроке приведены практические примеры использования формул массива в Excel. Это самый минимум из того, что с их помощью можно сделать. Надеюсь, что большая часть этих примеров, обязательно пригодится для решения Ваших повседневных задач.

Подсчет количества знаков в диапазоне ячеек

На рисунке ниже представлена формула, которая подсчитывает количество знаков, включая пробелы, в диапазоне A1:A10.

В данном примере функция ДЛСТР подсчитывает длину каждой текстовой строки из заданного диапазона, а функция СУММ – суммирует эти значения.

Наибольшие и наименьшие значения диапазона в Excel

Следующая формула возвращает 3 наибольших значения диапазона A1:D6

Чтобы возвратить другое количество наибольших значений, достаточно изменить массив констант. Например, следующая формула возвращает уже 6 наибольших значений того же диапазона:

Если необходимо найти наименьшие значения, просто замените функцию НАИБОЛЬШИЙ на НАИМЕНЬШИЙ.

Подсчет количества отличий двух диапазонов в Excel

Формула массива, представленная на рисунке ниже, позволяет подсчитать количество различий в двух диапазонах:

Данная формула сравнивает соответствующие значения двух диапазонов. Если они равны, функция ЕСЛИ возвращает ноль, а если не равны – единицу. В итоге получается массив, который состоит из нулей и единиц. Затем функция СУММ суммирует значения данного массива и возвращает результат.

Читайте также:  Где находятся картинки виндовс

Необходимо, чтобы оба сравниваемых диапазона имели одинаковый размер и ориентацию.

Транспонирование массива в Excel

Вспомним предыдущий пример и попробуем усложнить задачу. К примеру, требуется сравнить диапазоны в Excel, которые имеют одинаковый размер, но разную ориентацию – один горизонтальный, а другой вертикальный. В этом случае на помощь придет функция ТРАНСП, которая позволяет транспонировать массив. Теперь формула из прошлого примера, немножко усложнится:

Транспонировать массив в Excel – значит изменить его ориентацию, а точнее заменить строки столбцами, а столбцы строками.

Суммирование округленных значений в Excel

На рисунке ниже представлены товары, цена которых указана в евро, а также их количество и итоговая стоимость в рублях. В ячейке D9 отображается общая сумма всего заказа.

Если изменить форматирование в диапазоне D4:D8, то становится видно, что значения в этих ячейках не округлены, а всего лишь визуально отформатированы. Соответственно, мы не можем быть уверенны в том, что сумма в ячейке D9 является точной.

В Excel существует, как минимум, два способа исправить эту погрешность.

  1. Ввести в ячейки D4:D8 уже округленные значения. Формула массива будет выглядеть следующим образом:
  2. Использовать в ячейке D9 формулу массива, которая сначала округляет значения, а затем суммирует их.

Теперь мы можем быть уверенными в том, что сумма в ячейке D9 соответствует действительности.

Как видите, сумма до и после округления немного отличается. В нашем случае это всего лишь одна копейка.

Наибольшее или наименьшее значение по условию

На рисунке ниже представлен фрагмент таблицы продаж, в которой 1231 позиция. Наша задача посчитать максимальную продажу, которую осуществил заданный продавец.

Пусть в ячейке G3 мы будем задавать фамилию продавца, тогда формула массива будет выглядеть следующим образом:

В данном случае функция ЕСЛИ сравнивает значения диапазона B3:B1234 c заданной фамилией. Если фамилии совпадают, то возвращается сумма продажи, а если нет – ЛОЖЬ. В итоге функция ЕСЛИ формирует одномерный вертикальный массив, который состоит из сумм продаж указанного продавца и значений ЛОЖЬ, всего 1231 позиция. Затем функция МАКС обрабатывает получившийся массив и возвращает из него максимальную продажу. В нашем случае это:

Если массив содержит логические значения, то функции МАКС и МИН их игнорируют.

Чтобы вывести минимальную продажу, воспользуемся этой формулой:

Данная формула позволяет вывести 5 наибольших продаж указанного продавца:

Итак, в данном уроке мы рассмотрели несколько интересных примеров применения формул массива в Excel. Надеюсь, что они были для Вас полезны и обязательно пригодятся в будущем. Если желаете получить еще больше информации о массивах, читайте следующие статьи:

Ссылка на основную публикацию
Утилиты асус для ноутбука
Драйверы и утилиты от производителя для ноутбуков и нетбуков ASUS под операционную систему Windows 10 / 8.1 / 8 /...
Теплопроводность олова и меди
Все изделия, используемые человеком, способны передавать и сохранять температуру прикасаемого к ним предмета или окружающей среды. Способность отдачи тепла одного...
Терминальные лицензии windows server 2008 r2
Установка сервера терминалов в 2008/2008R2 2 часть / активация сервера терминалов 2008 r2 Установка сервера терминалов в 2008/2008R2 2 часть...
Утилиты для виндовс 10 64 бит
Скачать антивирус NOD32 на компьютер Windows 10 бесплатно на русском языке для защиты ноутбука или ПК от вирусов и потенциального...
Adblock detector